UnifiedViews Documentation

Downloads:

 

 

Skip to end of metadata
Go to start of metadata

Glossary: 

Plugin = Data processing unit = DPU

DPUs available

Before new DPU is prepared, you should check whether the DPUs does not already exist. Already existing DPUs:

Basic Concepts: 

To understand basic concepts for developing DPUs, please see: Basic Concepts for DPU developers.

Tutorials for Creation of DPUs for UnifiedViews 2.X (current version)

See: Tutorials

Where you should store newly create DPUs

How to select repository where the created Plugins (DPUs) should be published

DPUs for UnifiedViews 2.X versus DPUs for UnifiedViews 1.X

Since 1.4. 2015, release 2.X of UnifiedViews is available. Such release adjusts API and helpers (plugins development environment) used to develop DPUs. 

As a result, it is necessary to distinguish DPUs which were prepared for UnifiedViews 1.X and 2.X. 

If you develop new DPUs, you should develop DPUs for UnifiedViews 2.X.

Compatibility of DPUs developed for UnifiedViews version 1.X in UnifiedViews version 2.X

In order to migrate DPUs developed for 1.X version of UnifiedViews to DPUs working in 2.X version of UnifiedViews, please follow Guide to migrate old DPUs to new DPUs using helpers 2.0.

DPUs developed for 1.X version of UnifiedViews are not compatible with UnifiedViews 2.X as it is. In order to use DPUs developed for 1.X version of UnifiedViews in UnifiedViews 2.X, please follow Guide to ensure that older DPUs may run with 2.0.0 API/Helpers

 

 

  • No labels